Results 1 to 7 of 7

Thread: I've been busy

  1. #1
    Administrator Papee's Avatar
    Join Date
    Jan 2008
    Location
    PA/GA
    Posts
    2,705

    I've been busy

    A few weeks ago my jeep caught fire while I was welding on it. Bad ground, ground wires in the engine bay loom hot hot and burned. I tried to start it and drive it out of the garage. Oops, this put fuel on the fire because my gas lines burned off at the fuel rail. I pushed it outside and grabbed the hose to put it out. By then two of my neighbors were standing beside me with extinguishers.

    I called the insurance company, they totaled it and I bought it back.

    I had it running again two hours after the adjuster was here.

    Still lots to do but getting there.
    Please check out our YouTube channel and subscribe! Our YouTube Channel helps fund the site. Check it out at https://www.youtube.com/channel/UCTv...FrJP7yQVFVZnyA


  2. #2
    Administrator Papee's Avatar
    Join Date
    Jan 2008
    Location
    PA/GA
    Posts
    2,705

    Re: I've been busy

    Pics didnt post
    Attached Images Attached Images    
    Please check out our YouTube channel and subscribe! Our YouTube Channel helps fund the site. Check it out at https://www.youtube.com/channel/UCTv...FrJP7yQVFVZnyA


  3. #3

    Re: I've been busy

    Dang it that sucks!!!!!!!!!!

  4. #4
    New Member
    Join Date
    Oct 2017
    Posts
    20

    Re: I've been busy

    Quote Originally Posted by Papee View Post
    A few weeks ago my jeep caught fire while I was welding on it. Bad ground, ground wires in the engine bay loom hot hot and burned. I tried to start it and drive it out of the garage. Oops, this put fuel on the fire because my gas lines burned off at the fuel rail.
    You're saying that the welder completed it's needed circuit through the Jeep wiring? That seems rather unusual, but possible. Bad luck for you.

    Quote Originally Posted by Papee View Post
    I pushed it outside and grabbed the hose to put it out. By then two of my neighbors were standing beside me with extinguishers.

    I called the insurance company, they totaled it and I bought it back.

    I had it running again two hours after the adjuster was here.
    Bravo! Make sure you clean as much, if not all, of that doggone powder out of that engine bay. Over time, that stuff is corrosive. Good thing the welding didn't take the ECM.

    I see it's the 4.0. What year of YJ is that? I found a farm find, '92, but it's the 2.5 and 5-speed. Still working on that project.

    Roger

  5. #5
    Administrator Papee's Avatar
    Join Date
    Jan 2008
    Location
    PA/GA
    Posts
    2,705

    Re: I've been busy

    Yes unusual for sure but I'm pretty sure of it. The battery had no load on it when I disconnected it. All it took to restart it was two short fuel lines at the fuel rail.

    It's a 95 4.0 HO 4:10 5sp from the factory. One of the last 300 made. It's one of the late ones when they were running out of parts. They were in transition with the tj and some of the tj parts were used on it. Insurance gave me a pretty penny for it so I'm basically driving a free jeep now.
    Last edited by Papee; 07-12-2019 at 05:00 PM.
    Please check out our YouTube channel and subscribe! Our YouTube Channel helps fund the site. Check it out at https://www.youtube.com/channel/UCTv...FrJP7yQVFVZnyA


  6. #6
    New Member
    Join Date
    Oct 2017
    Posts
    20

    Re: I've been busy

    Hmmm. 4:10's behind a six banger? I thought that was a 3:73 ratio, or thereabouts.
    Not exactly the best way to make a score, but it sounds like you came up roses on that one.
    Looks like an air box and hose, maybe a master cylinder, and I think I'd replace that vacuum check valve on the booster, just for safety's sake.
    No damage to the diaphragm inside the booster?

    Roger

  7. #7
    Administrator Papee's Avatar
    Join Date
    Jan 2008
    Location
    PA/GA
    Posts
    2,705

    Re: I've been busy

    It's all done under the hood. The booster is ok. I replaced the master cyl, proportioning valve, all new brake lines in the front. Radiator overflow, a bunch of vaccum hoses including the check valve, air box, and other misc stuff.

    This jeep was special ordered with the 4:10s I'm the second owner had it fir five years now. It has about 132K on it.
    Please check out our YouTube channel and subscribe! Our YouTube Channel helps fund the site. Check it out at https://www.youtube.com/channel/UCTv...FrJP7yQVFVZnyA


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •